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1. What is Exodus? 
Exodus is a collection of software applications that assist in the automation of DICOM migration tasks. 
Exodus applications focus on reliability, flexibility, and a simplified user experience. 

Legacy archives often have features that present challenges for moving DICOM data, including: 

 Merger of two or more archives 

 Access to historical relevant priors 

 Mismatched patient/study information 

 Archive vendor proprietary issues 

 Private DICOM tag handling 

 Non-compliant/inconsistent DICOM data 

 Unknown size of the job 

 Uncertainty of completeness 

 Inability to validate the data moved 

 Excessive manual effort 

 Inability to pre-fetch relevant priors 

 Unresponsive support 
 
Exodus allows the user to automate the process of collecting the information needed from a legacy 
archive to assess, plan, configure, perform, and validate a DICOM Migration. This collected information 
can be used to assess exactly what data the user has and help decide exactly what needs to be moved 
and what needs to be changed. 

Using built-in validation and reporting systems, the user is able to determine exactly what has moved 
and what has not.  Exodus ensures that exams are moved in a timely way and that they are available for 
use in their entirety on the new archive - all automatically. 

From start to finish, the goal of Exodus is to provide a complete and transparent view of the issues 
related to moving DICOM studies, plus provide options to automatically control and report the 
movement of the DICOM data in a simple, high-level way; freeing the user to concentrate on other tasks. 

Exodus Applications 
Exodus comes in three basic application configurations: 
Certain features described in this document may not be applicable depending on the application in use: 

Exodus Migration Controller 

Migrate DICOM studies from one archive to anotherτthe complete archive migration solution. 

Exodus Assessment 
Assess the contents of the source archive prior to a migration and/or validate the results of a 

previous migration. 

Exodus Priors Fetcher 
Fetch prior exams when a patient becomes scheduled on the worklist. 
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2. Migration Basics  

2.1. Overview  

A data migration is defined as the process of transferring data from one location to another.  A 
determination of what exams should be moved is made and a list of exams to move are collected and 
subsequently moved.  To ensure that the exam was processed properly by the destination, a query may 
be issued to the destination to verify the existence and/or validity of the exam. 

2.2. Workflow  

DICOM migrations function through a set of third-party DICOM commands that allow a client to 
interrogate an archive for content and then selectively issue move requests to transfer that data to 
another system.  In the simplest case, the third-party client never sees the actual data: 

LŦ ǘƘŜ Řŀǘŀ ƴŜŜŘǎ ǘƻ ōŜ ŎƘŀƴƎŜŘ ƛƴ ŀƴȅ ǿŀȅ όŀƭǎƻ ƪƴƻǿƴ ŀǎ άfilteringέύ ƛǘ Ƴǳǎǘ pass through a system that 
can do so.  The main difference is that the move destination as far as the source is concerned is the 
system that will do the filtering.  This filtering system is responsible for forwarding the image on to the 
final destination: 

  

Query/Move Request 

Image Transfer 

Exodus 

Source 
Archive 

Destination 
Archive 

Image Transfer 

Validate Request 

Query/Move Request 

Image Transfer 

Exodus 

Source 
Archive 

Destination 
Archive 

Validate Request 
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3. Installation  

3.1. Minimum System Re commendations  

Core 2 Duo, 4GB RAM, 300GB HD, Windows XP (32-bit), Windows 7 (32-bit or 64bit),  Windows Server 
2003 R2 or better. 

3.2. Prerequisites  

Laurel Bridge Exodus utilizes several components that must be installed for it to work.  The prerequisites 
are: 
 

 Microsoft .NET Framework 3.5 SP1 

 Microsoft SQL Server 2005 Express or Microsoft SQL Server 2005 
 
The main install executable (setup.exe) will determine whether these prerequisites need to be installed 
and install them appropriately when necessary. 

3.3. Main Install  

After installing the prerequisites, the Exodus application installer (Exodus.msi) will run.  For machines 
with an older version installed, this installer will upgrade your previous install appropriately, while 
maintaining your configuration settings. 
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4. Getting Started  

4.1. Overview  

Exodus manages migrations by creating a database known as a session that contains all the 
configuration information as well as all the state and tag information for every exam it knows about.  
Groups of exams are viewed and operated upon by creating configurable views known as segments 
within a session. 
 
A session represents a separate database that stores configuration information about a migration.  
Information about the source, destination, and validation archives is included, as well as settings for 
each of these operations (e.g. timeouts, schedules, delays, etc.).  In addition to this information, the list 
and state of every query and exam is contained within a session which represents the work that has 
been done for a given migration.  While multiple sessions can be configured, typically only one is needed 
for a given migration. 
 
A segment provides the definition of what to query and represents a logical grouping of exams to 
migrate based on those queries.  There are multiple types of segments available allowing for various 
methods by which to gather listings of exams to work on.  A given migration can be broken up into 
multiple segments or left as one segment representing the entirety of the migration. 
 

Recommendation:  For DICOM Migrations of approximately 500,000 studies or more, Laurel 
Bridge recommends, if possible, that the migration be divided into multiple sessions within 
Exodus, each limited to no more than 500,000 studies.  Performance issues have been noted for 
sessions larger than 500,000 studies.   

4.2. Migration Types 

Exodus supports two types of migrations: File and Archive.  The type of migration defines where the 
source data is located.  For file-based migrations, data is collected recursively from a directory; for 
archive-based migrations data is housed in a DICOM-compatible archive.  Both migrations are processed 
very similarly and have: query phases where a list of exams is collected; move phases where the chosen 
exams are moved; and a validate phase where the moved exams are verified.  In fact, after indexing the 
information from the raw DICOM image files from disk into a built-in archive, file-based migrations 
function exactly like an archive-based one (i.e. ς both are communicating with a source archive ς one is 
simply built-in). 
 

4.3. Exodus Application Configurations  & License Options  

Exodus comes in three basic configurations: Exodus Migration Controller, Exodus Assessment, and 
Exodus Priors Fetcher.  Information on which version you are licensed for can be found by clicking Help 
> About Laurel Bridge Exodus.  Certain features described in this document may not be applicable 
depending on the application you are using: 

4.3.1. Exodus Migration Controller  

This application configuration is the complete archive migration solution, allowing the user to migrate 

DICOM studies from one archive to another: 
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 Provides functionality to assess, plan, perform, validate, and report activities associated with  
performing a DICOM migration from a single source archive to a single destination archive at a 
given site. 

 Includes advanced dataset filtering, tag morphing, and data element processing in real-time as 
data migrates, e.g., standardize dataset contents based on a master patient index or other site 
specific standards, rules, or workflows. 

 Includes all functions available in Exodus Assessment and Exodus Priors Fetcher (described 
below). 

4.3.2. Exodus Assessment 

This application configuration allows the user to assess the contents of the source archive prior to a 
migration or validate the destination data following a migration: 

 Provides functionality to query source DICOM archive to build Exodus database of study 
demographics, including ability to validate a previously performed DICOM migration. 

 Does NOT provide migration functionality, i.e., does not move studies from a source to a 
destination archive. 

 Provides ability to run pre-qualification algorithms against the imported DICOM demographic 
data. 
Pre-qualification criteria have been developed based upon typical problems encountered during 
a DICOM Migration, e.g., blank accession numbers, blank patient names, duplicate MRNs for 
same patient, etc. 
Results of this pre-qualification, or custom pre-qualification filters developed by customer, 
provides valuable information for developing migration strategy, including problem 
identification and mitigation.  

 Provides ability to validate a previous migration by comparing of source and destination using 
Exodus Validation rules and levels; includes the ability to generate comprehensive reports off 
what actually did migrate and what did not.  

4.3.3. Exodus Priors Fetcher  

This application configuration allows the user to fetch prior exams when a patient becomes scheduled 
on the Worklist. 

 Provides functionality to monitor a modality Worklist (or pseudo Worklist) to identify scheduled 
exams and move patient prior studies from a single DICOM source archive to a single DICOM 
destination. 

  

 Does NOT provide Exodus Assessment capabilities. 

 Does NOT permit the mass migration of studies via the standard processes available in Exodus 
Migration Controller ς only fetches one patientΩǎ ǇǊƛƻǊǎ at a time. 

4.3.4. License Mode: Charge By 

Exodus comes in two modes: Charge By Exam and Charge By Move.  Information on which mode you 
are licensed for can be found by clicking Help > About Laurel Bridge Exodus. 
 

 Charge By Exam: Licensed by number of exams (i.e. - a given exam can move multiple times and 
will only count against the total once). 
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 Charge By Move: Licensed by number of moves (i.e. ς a given exam can move multiple times, 
but will be counted against the total once for each move). 

4.3.5. License Mode: Segment Types 

Exodus can be configured to support any or all of the available segment types.  Information on which 
segment types you are licensed for can be found by clicking Help > About Laurel Bridge Exodus. 

4.4. Installing a License  

The first step after launching Exodus is to install a license.  When the registration dialog appears, click 
the [ƛŎŜƴǎŜΧ button, browse to your license file, and hit OK.  Information on the status of your license, 
including when it expires, can be found on this dialog available at any time by clicking Help > About 
Laurel Bridge Exodus. 

4.5. Creating a Migration  

To begin using Exodus to control a migration, you need to create a session to define the source and 
destination archives and at least one segment to define what queries you want to issue and the resulting 
exams you want to work on. 
 
To create a session, click File > New Session (or right-click in the Sessions / Segments panel and select 
New Session).  After you enter the desired session name a configuration dialog will appear that contains 
network settings for all the archives involved in the migration, alert settings for email notifications, and 
advanced settings for timeouts, rates, schedules, delays, try counts, etc.  Context help is available by 

clicking the  icon present next to each field in the dialog. 
 
To create a segment, select the new session and right-click New Segment in the Sessions / Segments 
panel.  After you enter the desired segment name a configuration dialog will appear that contains 
settings for the type, priority, and type-specific selection information.  Context help is available by 

clicking the  icon present next to each field in the dialog. 

4.6. Running a Migration  

After creating a session and at least one segment you can begin a migration.  To do so, check mark the 
desired segments in the Sessions / Segments panel, check mark the appropriate operations at the 
bottom of the main dialog (Query, Move, and Validate), and click the Run button on the toolbar.  The 
progress bars on the bottom of the screen will reflect how far along each of the selected operations are.  
Once there are no more operations to complete, the migration will automatically stop. 
 
While the operations can be run independently of one another, they are still sequential.  At least one 
successful query has to complete before there can be any exams eligible to move.  Similarly, at least one 
successful move has to complete before there can be any exams eligible to validate. 
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5. User Interface  Details  
To configure Exodus to control a migration you must first create a session to define the source and 
destination archives and then you must create at least one segment to define what queries to issue and, 
as a consequence, the resulting exams to work on. 

5.1. Sessions / Segments Panel 

The Sessions / Segments panel (shown in Figure 1) is available on the left hand side of the main window.  
It is a two-level tree control that contains and shows the available sessions (top level) ŀƴŘ ŜŀŎƘ ǎŜǎǎƛƻƴΩǎ 
available segments (bottom level). 
 

Only one session can be active at a time and is represented on the 
display by bold text (Figure 1 shows example session 1 as the currently 
active session and example session 2 as an inactive session).  Only the 
active session displays its segments, each of which can be checked to 
select it for viewing and running. 
 

When the migration is running, the checkboxes are replaced by icons representing the state of the 
segment.  A green icon means the segment is in progress.  A white icon means the segment is not 
currently loaded.  A red icon means some unexpected error has occurred (dynamic segments only).  A 
black icon means that the segment is currently loaded and complete. 
 

The session panel itself has a context menu (shown in Figure 2) available 
by right-clicking any blank space within in to access two options: 
 

 New Session: Creates a new session 

 Import Session: Imports a session from a file 
 
Each session entry also has a context menu (shown in Figure 3) available by right-click.  Note: some 
context menu options are disabled depending on whether the particular session is active or not and 
whether multiple sessions are selected. 
 

 Open: Activates a session 

 New Segment: Creates a new segment for a session 

 Save Report: Generates an import report (file-based 
migrations only) or a progress report about all of the contained 
segments and their composite exams contained within a session 

 Export: Exports a session, typically for backup 

 Clone: Creates a new session with the same settings and 
segments as the selected session 

 Advanced: Perform advanced options including optimizing 
the database, resetting query/move/validate errors, and resetting 
all query/move/validate progress (to redo all work) 

 Delete: Deletes a session 

 Rename: Renames a session 

 Properties: Displays the session configuration dialog 
 

Figure 1 - Sessions / Segment Panel 

Figure 3 - Session Context Menu 

Figure 2 - Sessions / Segment 
Panel Context Menu 
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Each segment also has a context menu (shown in Figure 4) available by right-click.  Note: certain options 

are disabled when multiple segments are selected. 
 

 Save Report: Generates a progress report about the exams 
contained within a segment 

 Generate Sample: Creates a sample of representative data from 
the given segment (selected by date and modality) 

 Advanced: Performs advanced options including resetting 
query/move/validate errors and resetting all query/move/validate 
progress (e.g., to redo all work) 

 Delete: Deletes a segment 

 Rename: Renames a segment 

 Properties: Displays the segment configuration dialog 

5.2. Session Configuration Dialog  

The session configuration dialog (shown in Figure 5) contains all the connectivity and alert information 

about a migration.  Details about each entry field are available by clicking the  icon next to a particular 
field.  The contents of the various menu tabs are described below. 
 

 Network: The network tab contains the 
connectivity information for the source, 
destination, and validation archives.  The validation 
archive is the system that responds to query 
requests after an exam is moved and is typically the 
same physical machine as the destination archive 
(unless routing occurs, for example).  Click the 
advanced button to specify validation archive 
information if it is different from the destination 
archive.  

 General: The general tab contains the migration 
type (archive or file-based), migration level (study 
or series), reset time/action, and the alert 
information including email server configuration, 
alert recipient, and alert type information.  The 
migration type and level cannot be changed after 
the session is created.    Email alerts are sent out to 
the specified email addresses depending on what 
events occur and what alert types are registered 
for.  When a stop trigger (certain number of successive failed query, move, or validate 
operations) is reached alerts are sent out to email addresses registered for Error Alerts.  When a 
new day is reached daily reports are sent out to email addresses registered for Daily Reports. 

 Query: The query tab contains specific information about the query operations including 
timeouts, try counts, delays, partitioning modes, and user defined tags.  User defined tags are 
non-ǎǘŀƴŘŀǊŘ ǘŀƎǎ ǘƘŀǘ ŀǊŜƴΩǘ ƴƻǊƳŀƭƭȅ ǊŜǉǳŜǎǘŜŘ ŘǳǊƛƴƎ ŀ ǉǳŜǊy.  Any DICOM tag can be 
queried, but there is no guarantee that an archive will return data for a particular tag.  See 7.1 
for more details on the query operation including user defined tags.   

Figure 5  - Session Configuration Dialog 

Figure 4 - Segment Context Menu 
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 Move: The move tab contains specific information about the query operations including 
timeouts, move order, pre-checks, try counts, delays, and schedule.  The move schedule is 
defined on a per hour basis with three basic modes: Normal, Off, and Rated.  During Rated 
mode, the configurable rate (given as a percentage) is used.  Right-clicking the move schedule 
will bring up a presets menu allowing you to select from popular schedule configurations.   See 
7.2 for more details on the move operation. 

 Validate: The validate tab contains specific information about the query operations including 
timeouts, try counts, delays, and rules.  Each validation rule consists of a set of options including 
the tags to use to find the exam on both the source and destination archives, level from which 
to obtain image count or list information for comparison, and comparison logic to use to 
compare the collected data (e.g. ς equal to, greater than, etc.).  See 7.3 for more details on the 
validate operation. 

 Filters: The filters tab contains the configuration window used to create image (dataset) filters 
that are used to change image information during the migration.  If image filtering is enabled all 
images are routed through Exodus (via C-STORE from the source) before being forwarded on the 
destination (via C-STORE to the destination).  The filtering mechanism can be configured to 
allow data transfer as uncompressed, compressed, or both (via forcing the source to negotiate a 
particular transfer syntax).  

 Test:  Selecting the test tab allows the user to initiate a series of connectivity and compatibility 
tests for the entered information.  It is recommended that any errors revealed by testing be 
addressed as they are likely the result of misconfiguration that will impede the migration or limit 
the information returned from the given archives. 

5.3. Segment Configuration Dialog  

The segment configuration dialog (shown in Figure 6) contains the information that defines a segment 
and the queries and exams the segment contains.  Each segment type has a different set of fields 
available that apply to that particular segment type.  Details about each entry field are available by 

clicking the  icon next to a particular field. 
 

 General: The general tab contains the segment type and 
general selection criteria for the segment.  The available types 
include Normal, Specific, List, Priors, and Fixed.  See section 6 
for more information on each segment type. 

× Normal: Provides a date range to query, one day 
at a time, backwards through time 

× Specific: Provides specific patient data to be 
queried in a single query 

× List: Provides a list of exams to query and move, 
provided by a file or command 

× Priors: Provides a set of patient matching 
requirements, used after querying for a list of patients from a modality worklist server 
or command-line output to then use to match against the exams queried from a source 
archive 

× Fixed: Used as a simple fixed list of studies, usually created by right-clicking an exam or 
ǎŜǘ ƻŦ ŜȄŀƳǎ ŀƴŘ ǎŜƭŜŎǘƛƴƎ ά!ŘŘ ¢ƻ {ŜƎƳŜƴǘέΦ 

 Advanced: The advanced tab contains specialized selection criteria used to refine the segment 
definition explicitly.  Also available is a move schedule that can be optionally enabled which will 

Figure 6 - Segment Configuration 
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override the global session move schedule.  The move schedule is defined on a per hour basis 
with three basic modes: Normal, Off, and Rated.  During Rated mode, the configurable rate 
(given as a percentage) is used.  Right-clicking the move schedule will bring up a presets menu 
allowing you to select from popular schedule configurations. 

5.4. Exam Viewer  

The exam viewer (shown in Figure 7) is 
available on the right hand side of the main 
window (if activated by clicking View > 
Exams) and contains a list of all the exams 
that are contained within any loaded 
segment (i.e., segments with a checkmark 
next to them). 
 
Columns can be reordered by dragging the column headers left or 
right within the viewer.  Columns can be sorted on by clicking on a 
particular column header.  The direction of the sort (i.e., ascending or 
descending) is toggled on each subsequent click.  Columns can be 
hidden by right-clicking on any column header and using the menu 
that appears (shown by Figure 8) to toggle the visibility of a particular 
column. 
 

Each exam listed in the viewer has a context menu (shown in Figure 9) 
available by right click.  Note: certain options are disabled if configuration 
information about specific archives (e.g., source, destination, validate) is 
missing. 
 

 Move: Move selected exam(s) after setting to Waiting 

 Validate: Validate selected exam(s) after setting to Moved 

 Fetch: Move selected  exam(s) to local machine  

 Set Status: Override the selected exam(s) status (setting to a 
status of Validated will set the status to be Validated (0) to indicate that it 
was validated manually) 

 Add to Segment: Add the selected exam(s) to a new or existing list segment 

 View History: View the move/validate history for selected exam 

 Copy: Copy the selected row(s)/cell text to the clipboard 

 Save: Save the selected exam(s) information to a file 
 
The exam search pane (shown in Figure 
10) is available above the exam viewer (if 
activated by clicking View > Exams Search 
or the small magnifying glass icon in the 
viewer title bar) and allows the list of 
exams displayed in the exam viewer to be limited by a set of match requirements.  This can be used to 
find a logical subset of all the loaded exams without defining a new segment.  Every column in the exam 
viewer can be used in the exam filter control with a number of match modes (e.g. Equal To, Greater 
Than, etc.).  The exam filter control only limits the exams displayed.  It does not, however, change the 

Figure 7 - Exam Viewer 

Figure 8 - Column Display Menu 

Figure 9 - Exam Menu 

Figure 10 - Exam Search Pane 
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loaded segment definitions.  Thus, if an exam is contained within a loaded segment it is still eligible to be 
moved and/or validated regardless of whether it is displayed in the viewer. 
 
To increase performance (especially when doing a large number of queries) the exam viewer can be 
locked (i.e., updates to the viewer are disabled) by clicking the small lock icon in the viewer title bar.  

5.5. Query Viewer  

The query viewer is available on the right hand side of the main window (if activated by clicking View > 
Queries) and displays a list of all the queries that are contained within any loaded segment (i.e., 
segments with a checkmark next to them).  Column display, context menu options, searching, and 
locking are similar to the exam viewer dialog options.  See section 5.4 for more details. 

5.6. History Dialog  

The history dialog (shown in Figure 11) is 
available by right-clicking on a single exam or 
query and selecting View History.  The entire 
history for a given item is listed with the time 
and result along with any comments (typically 
error comments). 
 
For validate operations each rule for a given 
score attempted is listed as a separate 
operation.  For each try the information that 
was returned from the source and validation 
archives is listed to the right in the Results 
panel.  A short explanation as to why a validation operation failed or passed is displayed in the 
Comments box. 
 

5.7. Operation Progress Panel  

The operation progress panel 
(shown in Figure 12) is 
available at the bottom of the 

main window and is used to display the individual progress of the Query, Move, and Validate operations 
for the loaded segments.  Each section of the operation panel has a checkbox to control whether that 
operation will run when a migration is run.  When running, these checkboxes are replaced by a spinning 
animation to indicate that a specific instance of a given operation (e.g., a single move) is occurring or a 
pulsing animation to indicate that a given operation is waiting for more work to do.  Progress is 
represented through a progress bar (blue for success and red for failure) as well as through numeric 
statistics below each progress bar.  The estimated amount of time remaining for a given operation is 
also displayed. 

5.8. Tool  Bar  

The tool bar (shown in Figure 13) is shown 
at the top of the main window and contains 
multiple buttons for controlling, 

Figure 12 - Operation Progress Panel 

Figure 13 ï Tool Bar 

Figure 11 ï Exam History Dialog 
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configuring, and viewing a migration. 
 

   Run : Starts a migration involving the selected operations on the loaded segments 

   Stop: Stops a migration (prompts if operation currently in progress) 

  [Session]: Displays the session context menu 

  [Segment]: Displays the segment context menu 

  [Record Log]: Starts full-detail logging to user-defined file for simplified debugging purposes 
 
In addition to these controls, an exam viewer row selector is available on the far right which displays the 
current selected row and the total number of rows available for display in the viewer. 

5.9. Menu Bar  

The menu bar (shown in Figure 14) is available at the top of the 
main window.  Menu drop-down options are: 
 

 File > New Session: Creates a new session 

 File > Import Session: Imports a session from a file 

 File > Record Log: Starts full-detail logging to user-defined file 

 File > Exit: Exits the program (after stopping migration) 
 

 View > Queries: Toggles the display of the query viewer 

 View > Exams: Toggles the display of the exam viewer 

 View > Queries Search: Toggles the activation/display of the query search pane 

 View > Exams Search: Toggles the activation/display of the exam search pane 

 View > Sessions / Segments: Toggles the activation/display of the session/segments viewer 

 

 Tools > Query Client: Displays a query dialog that performs C-FIND requests 

 Tools > Log Viewer: Displays a log viewer dialog with display filtering options 

 Tools > Options: Displays an options dialog to set program options (e.g. ς logging) 

 

 Help > Getting Started: Displays a guide on how get started with the program 

 Help > User Manual: Opens this user manual 

 Help > About Laurel Bridge Exodus: Displays an about dialog containing program and license 
information 

  

Figure 14 - Menu Bar 
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6. Segments 

6.1. Overview  

A segment provides the definition of what to query and represents a logical grouping of exams to 
migrate based on those queries.  There are multiple types of segments available allowing for a variety of 
ways to identify and gather collections of exams.  The set of queries done to gather exams may collect a 
larger list of exams into the database than will be shown in the segment display.  In other words, every 
ŜȄŀƳ ǊŜǘǳǊƴŜŘ ōȅ ŀ ƎƛǾŜƴ ǉǳŜǊȅ ǿƻƴΩǘ ƴŜŎŜǎǎŀǊƛƭȅ ōŜ ǇŀǊǘ ƻŦ ǘƘŜ ǎŜƎƳŜƴǘ that initiated the query.  This 
is because of the limited query functionality available in DICOM and especially in legacy archives.  A 
given migration (session) can be broken up into multiple segments or left as one segment representing 
the entirety of the migration. 
 
All segment types have segment-specific criteria as well as shared criteria including a Name, Priority, 
Custom SQL Selection String, and Move Schedule Override (except in Assessment versions of Exodus). 

6.2. Normal  Segment 

Normal segments are the most typical segment type for a historical (date-based) migration.  This 
segment type defines a Date range to query: one day at a time with the most recent date queried first.  
A Modality selector is also available with the option for Inclusive (i.e., that modality is included in list of 
modalities) or Exclusive (i.e., that modality is not included in list of modalities) logic. 

6.3. Specific Segment 

Specific segments allow for selective information to be gathered from a single query.  In order to limit 
the query scope a selective piece of information that is to be queried for must be included; typically 
these are: UID, Accession #, Patient Id, and/or Patient Name.  In addition, Date and Modality options 
are available to further restrict the selection criteria. 

6.4. List  Segment 

List segments allow for a list of exam UIDs to be provided to Exodus.  Each UID in the list will be queried 
to gather additional information about the exam.  Lists can be provided to Exodus as either a File or as 
the output of a Command.  This list can be repopulated on a configurable Interval. 

6.5. Priors  Segment 

Priors segments allow a list of relevant prior exams to be gathered from a particular Date range.  Exams 
are considered to be priors when they match based on a configurable set of criteria. The list of exams 
used to trigger a search for priors may come from a list of upcoming exams gathered from a Worklist 
server or from the standard output of a Command (see the format below).  The set of match tags that 
can be used include Patient Name, Patient Id, Patient Dob* , Patient Sex* , Modality, and Body Part* (* 
indicates a tag that is available when it has been added to the session as a user-defined tag).  The 
matching modes between the upcoming exam list and potential prior exams include Exact (matches 
values that match exactly), Smart (matches values in a criteria specific manner to avoid minor 
inconsistencies common to that specific tag), Map (matches values after translating upcoming exam 
values through a mapping given by a file), and Custom (matches values using a custom SQL string).  Prior 
exams are no longer considered priors after the upcoming exam they match has been off of the 
upcoming exam list, gathered at a given Interval, for more than the time given by the Fall Off time.  Each 
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new exam can match a given number of match criteria  specified by Max Matches.  The reset time and 
action (Charge By Move mode only) allows for exams to be reset to the Waiting state (with Reset 
action) or to be deleted (with the Delete state) after a configurable amount of time for use with 
transient/temporary destinations or large capacity sources. 
 
Smart priors matching follows these guidelines for comparing upcoming exam values with potential 
prior exam values (values are not case sensitive): 
 

 Patient Name: Matches when either name (after being stripped of spaces and carets) is a subset 
of the other (e.g. ς SMITH^BOB^J matches SMITH^BOB) 

 Patient Id: Matches by ignoring leading zeros (e.g. ς 0001234  matches 1234 ) 

 Patient Dob: Matches when dates differ by one day or less (e.g. ς 19900 101  matches 
19900102 ) 

 Patient Sex: Matches when first letter matches (e.g. ς Male  matches M) 

 Modality: Matches when upcoming exam value in an item in the list of values in the prior exam 
(e.g. ς MR matches MR\ CT) 

 Body Part: Matches when upcoming exam value in an item in the list of values in the prior exam 
(e.g. ς CHEST matches CHEST\ HEAD) 

 
Map priors matching functions the same for all tags.  Matches occur when the upcoming exam value is 
contained within a list of keys in a map file and the associated value for that key is contained within the 
list of values in the prior exam.  For example, if the upcoming exam has a value for Patient Id of 123456  
and the map file has a mapping for 123456  to 56789  then this will match any potential prior exam that 
has a Patient Id of 56789  and not one that has a value of 123456 .  As another example, if the upcoming 
exam has a value for Body Part of HEAD and the map file has a mapping for HEAD to BRAIN and HEAD to 
HEAD then this will match any potential prior exam that has a Body Part of HEAD or HEAD\ CHEST or 
BRAIN or BRAIN\ ARM, etc. 
 
The format of the standard output to be provided when using the Command mode to supply the list of 
exams follows an XML format, structured as follows: 
 

<Exams> 

<Exam 

PatientName=ò<name>ò 

PatientId=ò<id>ò 

PatientDob=ò<yyyymmdd>ò 

PatientSex=ò<sex>ò 

Modality=ò<modality>ò 

BodyPart=ò<body part>ò /> 

 ...  

<Exams> 

 

Notes:  
 Attributes are not required. 
 The order is not significant. 
 Newlines ŀǊŜƴΩǘ ǎƛƎƴƛŦƛŎŀƴǘΦ 
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6.6. Fixed Segment 

Fixed segments allow for a simple user-defined list of studies that are added through the user interface 
(as opposed to a file of UIDs, for example).  These segments are usually created and managed by right-
clicking on an ŜȄŀƳ ƻǊ ǎŜǘ ƻŦ ŜȄŀƳǎ ŀƴŘ ǎŜƭŜŎǘƛƴƎ ά!ŘŘ ¢ƻ {ŜƎƳŜƴǘέ ŀƴŘ άwŜƳƻǾŜ CǊƻƳ {ŜƎƳŜƴǘέΦ A 
fixed segment might be used to manually and pre-emptively move selected exams for a particular 
patient, for instance. 
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7. Operations  

7.1. Query 

Every segment definition results in a set of queries that are performed against the source archive one at 
a time.  Each query returns a set of exams that match the given query.  To protect against potential 
DICOM query limitations, some queries are purposefully made more generic than might be expected.  
The result of this is that not all of the exams that return necessarily match the exact segment definition.  
However, regardless of the precision of the query, the resulting exams are post-processed to mark only 
the exams that match the segment definition.  The end result is that each high level segment definition 
results in the appropriate, intelligent queries which will, in turn, provide the appropriate exam entries to 
the Exodus data base. 
 
Normally, the set of queries is defined at segment creation/modification time.  For dynamic segments 
like Priors and List, the query list changes periodically.  Thus, dynamic segments will never finish as far 
as the application is concerned.  Human assessment is required to determine when the dynamic 
segment is no longer needed.  For example, the Priors segment can fetch prior exams for any patient on 
the worklist server.  Since new patients can be added at any time, the segment is never truly complete.  
However, once all the exams on the source archive have been migrated, the segment is effectively 
complete.  This determination is not automatically made, but the human assessment can be aided by 
examining the completeness of a secondary segment that contains a list of all the exams on the source 
archive. 
 
Queries are tried a configurable number of times (until success) with a configurable timeout.  Once a 
query is marked as failed it must be manually reset (available in the segment and session context 
menus).  The delay in between queries is also configurable.  In addition to the standard tags displayed in 
the exam viewer, any other tag, known as a user-defined tag, can be requested during all queries.  These 
settings are found in the session configuration dialog. 
 
When migrating at the study level any user defined tag can have its query level overridden to the series 
level forcing a single query at the series level for each study returned in the base query.  The overridden 
tag will have its information coalesced from the information at the series level and grouped together by 
backslashes.  So, for example, if you wanted to fetch Body Part Examined, but you knew it was only 
available at the series level.  You would add a user defined tag for it (in the session configuration dialog) 
and override it by right-clicking the ǿƻǊŘ ά{ǘǳŘȅέ next to it and then selectƛƴƎ ά{ŜǊƛŜǎΦέ  In this example, 
the final returned study entries, that are stored in the internal database, would contain the Body Part 
Examined values from the series level. 

7.2. Move 

Each segment is made up of exams that match the given segment definition.  Each exam contained in a 
segment is eligible for move provided its status is Waiting. 
 
Each move is tried a configurable number of times (until success) with a configurable timeout.  Moves 
are skipped (and marked as Moved) if the move pre-check is configured and the score passes (the pre-
check process is identical to the validation process and can be thought of as pre-move validation where 
a certain score must be met to skip the move).  The number of simultaneous moves is also configurable 
and may be limited due to configuration settings on the source archive.  The move schedule that defines 
the delay in between moves and when moves should not take place is also configurable on a per hour 
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basis.  Delays between moves are available in Rated mode and are a function of the percentage of the 
duration of the most recent move.  These settings are found in the session configuration dialog. 
 
Exams with failed move status can be reset individually by the exam viewer context menu or at the 
segment/session level through the segment and session context menus.  This is typically done to cause 
the exam move to be retried. 

7.3. Validate  

Each exam contained in a segment is eligible for validation provided its status is Moved (when using the 
Exodus Assessment application the necessary status is Waiting).  The purpose of validation is to ensure 
that exams were successfully received and processed by the destination archive.  The validation archive 
can be, and generally is, the same archive as the destination unless the destination is a router or 
gateway. 
 
Validation consists of applying a set of rules, with a given rank, where each rule is processed (starting 
with rank 1) until a successful match is found.  The resulting validation rank is the highest (i.e., lowest 
numbered) rank for which a match occurred.  Thus, more stringent requirements should be used for 
higher ranks. 
 
The first step in validation is to locate each exam or set of exams on the source and destination archives.  
Each rule consists of a configurable set of tags specified by the Tags list that will be used as the match 
tags in the queries to the source and destination.  The matching values used are the values collected 
previously during the initial query phase of the migration.  Depending on which tags are used and the 
content of each archive, one or more exams may be returned from each archive.  In the ideal situation, 
validation would have one rule, matching solely on the exam UID, to return one result from each 
archive.  However, since UIDs can potentially be changed during a migration, either intentionally or 
otherwise, this is not always possible.  Choosing a different set of match tags can provide an alternate 
way of locating exams as well as a way to ensure that certain tags were not changed.  However, if one or 
more of those tag values are changed during migration that exam will not be located on the destination.  
Thus, care should be taken to choose the appropriate match tags that will ensure that exams will be 
located correctly. 
 
The next step is to determine from which level data will be obtained; this is designated by the Level 
selection.  The options include Study which is a count of the number of images in a particular study 
(Number of Study Related Instances), Series which is a count of the number of images in each of the 
series in a particular study (Number of Series Related Instances), and Image which is a list of all the 
images in a particular study (SOP Instance UID).  This decision is generally determined by the capabilities 
of the archives involved, as some systems do not support certain options.  Image level validation is 
stricter as it requires that not only the counts match, but that the exact list of images are the same. 
 
The next step is to determine how the data collected is compared; this is designated by the Comparison 
selection.  When retrieving count information (Study or Series), the options for comparison are 
numerically based (e.g. ς Equal To, Greater Than, Less Than or Equal To, etc.) or list based (e.g. ς Equal 
To, Contains, etc.) when retrieving list information (Image level).  Note, that if either the source or the 
destination is set to return count information, then numerical based comparisons are used, as the list 
data is converted to count data for comparison (e.g. ς ŀ ƭƛǎǘ ƻŦ р ƛƳŀƎŜǎ ǿƛƭƭ ōŜ ŎƻƴǾŜǊǘŜŘ ǘƻ άрέύΦ  This 
allows for flexibility in terms of the comparison such that, for example, any exam that has at least as 
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many images for a particular study on the validation archive as on the source archive can be considered 
a match.  The options should be read as: 
άǊŜǎǳƭǘǎ ŦǊƻƳ ǎƻǳǊŎŜ ŀǊŎƘƛǾŜ ŀǊŜ ғcomparison option> the results from the ǾŀƭƛŘŀǘƛƻƴ ŀǊŎƘƛǾŜέΦ  

 
The last step is to determine how duplicates and multiple responses are processed, if allowed, as 
designated by the Duplicates and Multiples selections.  When retrieving count information (e.g. ς Study 
Image Count), the options are numerical based (e.g. ς Sum, Max, Min, etc.) and list based (e.g. ς 
Unique) when retrieving list information.  Duplicate responses for count based selections (Study or 
Series) occur when more than a single DICOM C-FIND response for a given UID is returned.  For list 
based selection (Image), duplicates occur when a duplicate image UID is returned. Duplicates are 
symptomatic of some DICOM incompatibility.  Multiple responses occur when more than single exam 
UID is returned and would typically only be allowed when validation is expected to find multiple exams 
on either the source or the destination (e.g. ς two exams are intentionally merged during the migration).  
These settings represent advanced capabilities and should only be used for specific cases.  As such, the 
default is to Disallow these types of responses, resulting in a failed validation step.  
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8. Filters  
Filters allow image (or dataset) header elements to be changed as Exodus receives them from the 
Source archive.  Filters can also be used to modify DICOM C-FIND and C-MOVE messages as they are 
sent/  received to/from the Source and Destination archives. 

A new Filter can be created 
by selecting the Filters tab 
on the Session Properties 
Dialog (Figure 15).  The 
special C-FIND and C-MOVE 
filters can be created from 
the Query, Move and 
Validate tabs.   

To add a dataset filter, 
press the green plus button 
located under the Filters 
list.  This will create a new 
CƛƭǘŜǊ ǿƛǘƘ ǘƘŜ ƴŀƳŜ άbŜǿ 
CƛƭǘŜǊ Κέ ǿƘŜǊŜ ά?έ is the 
next available number, 
starting at 1.  Filter names 
are customizable and can 
be modified at any time by 
clicking on the name.  The 
list of Filters may be reordered by selecting a Filter and then pressing the up or down arrows under the 
list display box.  Filters are applied in order, top to bottom, so ordering is important. 

Once a Filter place holder has been created the next step is to configure its Conditions and Actions. 

8.1. Conditions  

! CƛƭǘŜǊΩǎ Conditions determine whether or not its Actions 
will be applied to the image being processed.  A Filter may 
have multiple conditions, therefore option are provided 
that all Conditions must match όάaŀǘŎƘ !ƭƭέύ or any Conditions can match in order όάaŀǘŎƘ !ƴȅέύ for the 
Filter to be applied.  The other configuration is to have no Conditions, thereby causing the filter to be 
always applied with no conditional matching. 

For each Condition select the Dicom Tag condition type (additional types may be added in the future).  
Configure the rest of the Condition based upon the desired test.  Conditions may be removed by 
pressing the red minus sign located to the left of each condition, and sorted via the up and down arrow 
buttons. 

8.2. Original Attribute Sequence  

The original tag value of a filtered tag can optionally be stored in the DICOM original attribute sequence 
by checking the Create Original Attribute Sequence checkbox.  If left unchecked, the original values 
modified by the filter will not be recorded in the original attribute sequence. 

 

Figure 15 - Session Properties, Filters Dialog 
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8.3. Standard Actions  

If the Conditions testing is satisfied, then any Actions defined by a filter will be applied to the image / 
dataset. 
 

 The Change Case action changes the case of the selected tag to either upper-case or lower-case. 

 
 

 The Copy action copies the tag specified in the From field to the tag specified in the To field. 

 
 

 The Execute action executes a piece of speciality custom code that is stored in a local file and that 
adheres to a particular coding interface.  For example: 

public class DateComparisonFilter : IFilterAction  

{  

public void ApplyAction(CFGGroup config, DicomSessionSettings dss, 

RelevantTagMarker tagMarker, ref DicomDataSet dds)  

 {  

  // custom code  

 }  

}  

Note: Contact Laurel Bridge Software for more information on creating custom Execute filters. 
 

 
 

 The Find/Replace action changes the value of the selected tag via hardcoded values or Perl/Java/C# 
style regex values. 

 
 

 The Insert/Overwrite action creates the specified Tag όƛŦ ƛǘ ŘƛŘƴΩǘ ŀƭǊŜŀŘȅ ŜȄƛǎǘύ ƻǊ ƻǾŜǊǿǊƛǘŜǎ ǘƘŜ 
specified tag (if it did already exist) with the specified Value. 

 
 

 The Move action moves the tag from its original location to its final location.  Once moved, the tag 
will not be present in its original location.  Note that this is not the same as the copy action. 

 
 

 The New UID action replaces the Unique Identification (UID) value of the specified UID type tag in 
the Tag field with a new, auto-generated UID value. 
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 The Pad action pads the specified tag with the specified character.  The Left and Right radio buttons 
specify whether to pad the left or right side of the value.  The new total length of the tag value is 
specified by the Length field.  If the length of the original value is equal to or greater than the Length 
field, the value will not be changed. 

 
 

 The Prepend/Append ŀŎǘƛƻƴ ǇǊŜǇŜƴŘǎ ƻǊ ŀǇǇŜƴŘǎ ǘƘŜ ǎǇŜŎƛŦƛŜŘ ǘŜȄǘ ǘƻ ǘƘŜ ǎǇŜŎƛŦƛŜŘ ǘŀƎΩǎ ǾŀƭǳŜΦ 

 
 

 The Remove action removes the specified tag.  If the Only if Empty checkbox is checked, the tag will 
ōŜ ǊŜƳƻǾŜŘ ƻƴƭȅ ƛŦ ǘƘŜ ǎǇŜŎƛŦƛŜŘ ǘŀƎΩǎ ǾŀƭǳŜ ƛǎ ŜƳǇǘȅΦ 

 
 

 The Trim action removes the specified characters from the left, right, or both sides of the specified 
ǘŀƎΩǎ ǾŀƭǳŜΦ  

 

 The Drop Image action drops any images (datasets) that match the conditions and then returns 
either a successful C-STORE Response message or a failure C-STORE response message to the Source 
archive. 
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8.4. Mapping List Action  

Overview:   

The Mapping List action allows the user to define and specify an external file that lists match tags and 
replace tags.  When creating a Mapping List action in Exodus, the user specifies the format of the 
mapping list file to be used.  The example below shows that the mapping list file will contain three 
comma-separated fields, in this caseΥ ŀƴ ŀŎŎŜǎǎƛƻƴ ƴǳƳōŜǊΣ ŀ ǇŀǘƛŜƴǘ L5Σ ŀƴŘ ŀ ǇŀǘƛŜƴǘΩǎ ƴŀƳŜΦ  LŦ ǘƘŜ 
match tags on any given row match the current dataset, the values of the replace tags are substituted 
into the dataset.  Below is an example of a mapping list file that matches the format specified by the 
mapping list action below: 
 
Mapping list file contents: 
 

PIKR0004,PAT124,SMITH^JOSEPH  

ABC123,PAT45,MINER^STEVEN 

 
Mapping list action specification: 
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Example: Creating a Mapping List filter 

Create your Mapping List Filter under the Filters tab of the Session Properties Dialog: 

The Actions section has limited screen space and you have to scroll to see it in pieces.  You can increase 
the size of that area of the dialog box by hovering slightly above the Actions label and getting a handle 
to that portion of the screen.  Examples of scrolling the Actions are shown in the three screenshots 
below. 
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If you look at all three of the previous example ǎŎǊŜŜƴ ǎƘƻǘǎ ƛƴ ǎǳŎŎŜǎǎƛƻƴ ȅƻǳΩƭƭ ǎŜŜ selected a mapping 
list filter that uses a comma delimited file called c:\MapFilter.csv and that should contain three match 
ǘŀƎǎ ό!ŎŎŜǎǎƛƻƴ ƴǳƳōŜǊΣ tŀǘƛŜƴǘ L5 ŀƴŘ tŀǘƛŜƴǘΩǎ {ŜȄ were chosen in this example, although any tags 
may be chosen); and two replacemŜƴǘ ǘŀƎǎ όtŀǘƛŜƴǘΩǎ bŀƳŜ ŀƴŘ tŀǘƛŜƴǘ L5 were chosen in this 
example). Note that in screen 1 ǘƘŜ άbƻ aŀǘŎƘέ ŀŎǘƛƻƴ ƛǎ ǎŜǘ ǘƻ ά!ōƻǊǘ !ǎǎƻŎƛŀǘƛƻƴέΣ ǘƘƛǎ ƳŜŀƴǎ ǘƘŀǘ ƻƴƭȅ 
datasets that match an entry will be moved, others will not be moved. 

To the left of each tag on the screen is the Column number ς which indicates which column in the file 
contains that data element. 

IŜǊŜΩǎ ŀƴ ŜȄŀƳǇƭŜ ƻŦ ǿƘŀǘ a MapFilter.csv file might look like for the sample definition: 

 
Please note that this is a contrived example; in practice, a mapping list file like this should not ever be createdτthe first two 
lines show two different patients with the same Patient ID.  This example is used to make a point about matching rules below. 
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IŜǊŜΩǎ the Exodus main Screen after attempting a migration.  Since the MapFilter.csv was so small, only 
the first two exams visible in the exam viewer below partly matched the mapping list criteria. 

 
 

The Query tool shows that the (first and only) moved study contains data from line 2 of the mapping list 
CSV file; note that this study ŘƛŘƴΩǘ ƳŀǘŎƘ ƭƛƴŜ м since ǘƘŜ άǎŜȄέ field did not match. 
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The second study listed on the Exodus main screen ŘƛŘƴΩǘ ƳƻǾŜ ς Query Tool shows that on the source 
archive for that study UID, patient Michelle 5ŀǾƛǎ ǿŀǎ ƳŀǊƪŜŘ ŀǎ ƘŀǾƛƴƎ DŜƴŘŜǊ άaέ ǎƻ ƛǘ ǿŀǎƴΩǘ ŀ 
match.  The άbƻ ƳŀǘŎƘ ŀŎǘƛƻƴέ ǿŀǎ ǎŜǘ ǘƻ ά!ōƻǊǘ !ǎǎƻŎƛŀǘƛƻƴΣέ ǿƘƛŎƘ ŎŀǳǎŜŘ ǘƘŜ aƻǾŜ ǘƻ ŦŀƛƭΦ  LŦ ǘƘŜ άbƻ 
ƳŀǘŎƘ ŀŎǘƛƻƴέ ƘŀŘ ōŜŜƴ ǎŜǘ ǘƻ ά/ƻƴǘƛƴǳŜΣέ then the exam would have moved, but its header data would 
not have been modified. 
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Appendix A: How to not migrate (drop) non-image DICOM objects 

If a user wants to drop a non-image type of object, such as a structured report (SR), he can create a filter 
with a Drop Action set to Drop the particular type of instance.  However, one must be aware that this 
action could result in Validation failures because there will be missing instances on the Destination 
PACS when it comes time to compare source and destination files. 
 
One way to work around this is to create a second validation rule that will query at the Image level of 
the source system and drop any C-FIND Response DIMSE messages (C-FIND-RSP) that contain a response 
for the given non-image object type. 
 
ExampleτDo not migrate Structured Report objects: 

Let us assume we need to drop all Basic Text Structured Reports (DICOM SOP Class: 
1.2.840.10008.5.1.4.1.1.88.11) 
 
Step 1: Create a tag filter to Drop any Instance of DICOM Basic Text SR and return a C-STORE-RSP of 
success.  Displayed below is the Filters Tab of the Session Properties Dialog showing this configuration. 

 
 


















